您的位置:首页 > 其它

HDOJ 233 Matrix 5015【矩阵快速幂】

2015-08-15 19:19 330 查看

233 Matrix

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1355 Accepted Submission(s): 806



Problem Description

In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means
a0,1 = 233,a0,2 = 2333,a0,3 = 23333...) Besides, in 233 matrix, we got ai,j = ai-1,j +ai,j-1( i,j ≠ 0). Now you have known a1,0,a2,0,...,an,0, could you tell
me an,m in the 233 matrix?


Input

There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 109). The second line contains n integers, a1,0,a2,0,...,an,0(0 ≤ ai,0 < 231).


Output

For each case, output an,m mod 10000007.


Sample Input

1 1
1
2 2
0 0
3 7
23 47 16




Sample Output

234
2799
72937

Hint





Source

2014 ACM/ICPC Asia Regional Xi'an Online


Recommend

hujie | We have carefully selected several similar problems for you: 5390 5389 5388 5387 5386


题意:求矩阵anm的元素,第一行0,233,2333,23333,。。。。然后给n个元素代表第i行第一列,ai0 元素..... aij
= ai-1,j+ai,j-1 ....就根据这个公式算出所有元素。然后输出anm


解题分析:

此题一看就是裸快速幂~因为m比较大。开始的时候是想直接推算出整个矩阵,后来发现推不出来。然后就得想到推下一列。就是有第一列推第二列,第二列推第三列。。。。等等。。

我们先写几个元素

a[1]

a[2]

a[3]

想到有233~得出来这个数啊。

23

a[1]

a[2]

a[3]

3

推下一列有:

23*10+3

a[1]+23*10+3

a[2]+a[1]+23*10+3

a[3]+a[2]+a[1]+23*10+3

3

然后转移矩阵A就可以推出来了:

10 0 0 0 1

10 1 0 0 1

10 1 1 0 1

10 1 1 1 1

0 0 0 0 1

然后对A求快速幂,再乘以a数列就可以了

#include <stdio.h>
#include <math.h>
#include <vector>
#include <queue>
#include <string>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>

using namespace std;

typedef long long LL;
const int Modn = 10000007;
const int MAXN = 15;
LL res[MAXN][MAXN];
int N;

void Matmul(LL X[MAXN][MAXN],LL Y[MAXN][MAXN])
{
    LL t[MAXN][MAXN]={0};
    for(int i=0;i<N;i++)
        for(int k=0;k<N;k++)
            if(X[i][k])
            for(int j=0;j<N;j++)
            t[i][j]=(t[i][j]+X[i][k]*Y[k][j]%Modn)%Modn;
    for(int i=0;i<N;i++)
        for(int j=0;j<N;j++)
            X[i][j]=t[i][j];
}

void Matrix(LL X[MAXN][MAXN],LL n)
{
    for(int i=0;i<N;i++)
        for(int j=0;j<N;j++)
        res[i][j]=(i==j);
    while(n){
        if(n&1) Matmul(res,X);
        Matmul(X,X);
        n>>=1;
    }
}

int main()
{
    LL n;
    LL m;
    while(scanf("%lld%lld",&n,&m)!=EOF){
        LL a[MAXN];
        LL A[MAXN][MAXN];
        memset(A,0,sizeof(A));
        N=n+2;
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        a[0]=23;a[n+1]=3;
        for(int i=0;i<N;i++){
            if(i!=N-1)A[i][0]=10;
            for(int j=1;j<=i;j++){
                if(i!=N-1)A[i][j]=1;
            }
            A[i][N-1]=1;
        }
        Matrix(A,m);
        LL ans=0;
        //for(int i=0;i<N;i++)
        for(int j=0;j<N;j++){
                ans=(ans+a[j]*res[N-2][j]%Modn)%Modn;
        }
        printf("%lld\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: