您的位置:首页 > 其它

As Easy As A+B

2015-08-15 17:10 417 查看


As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 46460    Accepted Submission(s): 19869


[align=left]Problem Description[/align]
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!

 

[align=left]Input[/align]
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and
then N integers follow in the same line.

It is guarantied that all integers are in the range of 32-int.

 

[align=left]Output[/align]
For each case, print the sorting result, and one line one case.

 

[align=left]Sample Input[/align]

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

 

[align=left]Sample Output[/align]

1 2 3
1 2 3 4 5 6 7 8 9

 

[align=left]Author[/align]
lcy
 

[align=left]Recommend[/align]
We have carefully selected several similar problems for you:  1096 1090 1029 1091 1093 As
Easy As A+B

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 46460 Accepted Submission(s): 19869

Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in
the same line.

It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

2

3 2 1 3

9 1 4 7 2 5 8 3 6 9

Sample Output

1 2 3

1 2 3 4 5 6 7 8 9

Author

lcy

Recommend

We have carefully selected several similar problems for you: 1096 1090 1029 1091 1093
#include<stdio.h>
#include<stdlib.h>
int cmp(const void*a,const void*b){
return(*(int*)a-*(int*)b);
}
int main(){
int n;
scanf("%d",&n);
while(n--){
int N,a[1005],i;
scanf("%d",&N);
for(i=0;i<N;i++)
scanf("%d",&a[i]);
qsort(a,N,sizeof(a[0]),cmp);
for(i=0;i<N;i++){
printf("%d",a[i]);
if(i!=N-1)
printf(" ");
}//注意:最后一个元素后无空格直接换行
printf("\n");
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: