您的位置:首页 > 其它

Hdu_1003_Max Sum 解题心得

2015-08-15 17:04 288 查看
原题:

Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

Sample Output

Case 1: 14 1 4 Case 2: 7 1 6

分析:
求最大字段和,d[i]表示已 i 结尾(字段和中包含 i )在 a[1..i] 上的最大和,d[i]=(d[i-1]+a[i]>a[i])?d[i-1]+a[i]:a[i];
max = {d[i],1<=i<=n} 这就是状态转移方程

代码:

#include <iostream>
#include<cstdio>
using namespace std;
int main()
{
int j, i, k, n, m, t;
int a;
scanf("%d", &t);
for (j = 1; j <= t; j++)
{
scanf("%d", &n);
int sum = 0, maxsum = -1001, first = 0, last = 0, temp = 1;
for (i = 0; i<n; i++)
{
scanf("%d", &a);
sum += a;
if (sum > maxsum)
{
maxsum = sum; first = temp; last = i + 1;
}
if (sum < 0)
{
sum = 0; temp = i + 2;
}
}
printf("Case %d:\n%d %d %d\n", j, maxsum, first, last);
if (j != t)
{
printf("\n");
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: