您的位置:首页 > 其它

hdu 5135 Little Zu Chongzhi's Triangles 贪心

2015-08-15 12:05 375 查看

Little Zu Chongzhi's Triangles

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 512000/512000K (Java/Other)
Total Submission(s) : 3 Accepted Submission(s) : 3
[align=left]Problem Description[/align]
Zu Chongzhi (429–500) was a prominent Chinese mathematician and astronomer during the Liu Song and Southern Qi Dynasties. Zu calculated the value ofπ to the precision of six decimal places and for a thousand years thereafter no subsequent
mathematician computed a value this precise. Zu calculated one year as 365.24281481 days, which is very close to 365.24219878 days as we know today. He also worked on deducing the formula for the volume of a sphere.

It is said in some legend story books that when Zu was a little boy, he liked mathematical games. One day, his father gave him some wood sticks as toys. Zu Chongzhi found a interesting problem using them. He wanted to make some triangles by those sticks, and
he wanted the total area of all triangles he made to be as large as possible. The rules were :

1) A triangle could only consist of 3 sticks.

2) A triangle's vertexes must be end points of sticks. A triangle's vertex couldn't be in the middle of a stick.

3) Zu didn't have to use all sticks.

Unfortunately, Zu didn't solve that problem because it was an algorithm problem rather than a mathematical problem. You can't solve that problem without a computer if there are too many sticks. So please bring your computer and go back to Zu's time to help
him so that maybe you can change the history.

[align=left]Input[/align]
There are no more than 10 test cases. For each case: The first line is an integer N(3 <= N<= 12), indicating the number of sticks Zu Chongzhi had got. The second line contains N integers, meaning the length of N sticks. The length
of a stick is no more than 100. The input ends with N = 0.

[align=left]Output[/align]
For each test case, output the maximum total area of triangles Zu could make. Round the result to 2 digits after decimal point. If Zu couldn't make any triangle, print 0.00 .

[align=left]Sample Input[/align]

3
1 1 20
7
3 4 5 3 4 5 90
0


[align=left]Sample Output[/align]

0.00
13.64


贪心原则:能组成三角形的小棍子越长,所得到的面积越大。从最大开始查找,只要满足情况,这组留下,不满足三角形,最大的抛弃,一次向下再找一个

注意:题目解决使用海伦公式: p=(a+b+c)/2; area=sqrt(p*(p-a)*(p-b)*(p-c));

如果通过三角函数间接计算的话,误差天大。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int cmp(double a ,double b)
{
return a>b;
}
double Area(double a,double b ,double c)
{
double p=(a+b+c)*1.0;
p/=2;
return sqrt(p*(p-a)*(p-b)*(p-c));
}
int map[110];
int main()
{
int n;
int i,j;
double area;
while(scanf("%d",&n),n){
memset(map,0,sizeof(map));
for(i=0;i<n;i++)
{
scanf("%d",&map[i]);
}
sort(map,map+n,cmp);
area=0;
for(i=0;i<n-2;i++)
{
if((map[i+1]+map[i+2])>map[i])
{
area+=Area(map[i],map[i+1],map[i+2]);
i+=2;
}
}
printf("%.2f\n",area);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: