您的位置:首页 > 其它

HDU - 3631 Shortest Path(Floyd最短路)

2015-08-15 11:12 309 查看
Shortest Path

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u
SubmitStatus

Description

When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.

There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:

(1) Mark a vertex in the graph.

(2) Find the shortest-path between two vertices only through marked vertices.

For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets
problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.

Could you also solve the shortest-path problem?

Input

The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000;
and Q is the number of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y),
and the weight of the arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There
is a blank line between two consecutive test cases.

End of input is indicated by a line containing N = M = Q = 0.

Output

Start each test case with "Case #:" on a single line, where # is the case number starting from 1.

For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.

For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.

There is a blank line between two consecutive test cases.

Sample Input

5 10 10
1 2 6335
0 4 5725
3 3 6963
4 0 8146
1 2 9962
1 0 1943
2 1 2392
4 2 154
2 2 7422
1 3 9896
0 1
0 3
0 2
0 4
0 4
0 1
1 3 3
1 1 1
0 3
0 4
0 0 0


Sample Output

Case 1:
ERROR! At point 4
ERROR! At point 1
0
0
ERROR! At point 3
ERROR! At point 4


Source
2010 Asia Regional Tianjin Site ―― Online Contest

题意:有向图,有重边。选中一些点,在这些点里面求两点的最短路。有2个操作,操作 "0" 表示标记 x 选中,如果x之前已经被选中,输出 "ERROR! At point x"。操作 "1" 表示求 x ->y 的最短路,如果x或y不在选中的点里面,输出 "ERROR! At path x to y",如果有不存在则输出 "No such path"。

思路:初始化 vis 数组为-1,表示全部未被选中,之后标记 vis[x] 为0表示 x 被选中,更新Floyd,把 x 点作为中间点更新最短路数组。

<span style="font-size:18px;">#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
using namespace std;

#define ll long long
const ll INF = 1<<30;
const double PI = acos(-1.0);
const double e = 2.718281828459;
const double eps = 1e-8;
int n, m, t;
const int MAXN = 310;
ll g[MAXN][MAXN];
int vis[MAXN];

void Floyd(int k)
{
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
if(g[i][j] > g[i][k]+g[k][j])
g[i][j] = g[i][k]+g[k][j];
}
}
}

int main()
{
//freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);
int num = 1;
while(cin>>n>>m>>t)
{
if(!n && !m && !t)
break;
memset(vis, -1, sizeof(vis));
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
g[i][j] = (i==j)?0:INF;
}
}
//cout<<g[4][5]<<endl;
int p, q, x, y;
ll w;
for(int i = 1; i <= m; i++)
{
scanf("%d %d %I64d", &p, &q, &w);
if(g[p][q] > w)
g[p][q] = w;
}
if(num != 1)
printf("\n");
printf("Case %d:\n", num++);
while(t--)
{
scanf("%d", &q);
if(q == 0)
{
scanf("%d", &x);
if(vis[x] == 0)
printf("ERROR! At point %d\n", x);
else
{
vis[x] = 0;
Floyd(x);
}
}
else
{
scanf("%d %d", &x, &y);
if(vis[x]==-1 || vis[y]==-1)
printf("ERROR! At path %d to %d\n", x, y);
else
{
if(g[x][y] != INF)
printf("%I64d\n", g[x][y]);
else
printf("No such path\n");
}
}
}
}
return 0;
}

</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: