您的位置:首页 > 其它

2367 Genealogical tree

2015-08-14 21:10 330 查看
Genealogical tree

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3685 Accepted: 2453 Special Judge
Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of
children. Martians have got used to this and their style of life seems to them natural. 

And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than
to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake
first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 

Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further,
there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it
is empty) ends with 0.
Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.
Sample Input
5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output
2 4 5 3 1


拓扑排序,不过这个题的题意比较难懂,说的是:给出一个数,代n个人,然后下面n行依次对应第几个人的后代,最后按辈分高低输出.....

刚开始没看懂题意,wa,后来发现了问题,才改正确........

注意格式....

#include<stdio.h>
#include<string.h>
int n,x[105][105],ind[105];
void tpsort()
{
int i,j,k;
for(i=0;i<n;++i)
{
for(j=1;j<=n;++j)
{
if(ind[j]==0)
{
break;//跳出
}
}
if(i<n-1)
{
printf("%d ",j);//输出
}
else
{
printf("%d\n",j);
return;
}
ind[j]=-1;//标记
for(k=1;k<=n;++k)//去掉无效边
{
if(x[j][k])
{
--ind[k];
}
}
}
}

int main()
{
int i,j,a;
while(~scanf("%d",&n))
{
memset(x,0,sizeof(x));
memset(ind,0,sizeof(ind));
for(i=1;i<=n;++i)
{
while(scanf("%d",&a),a)//注意格式
{
if(!x[i][a])//统计.注意操作对象..
{
x[i][a]=1;
++ind[a];
}
}
}
tpsort();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: