您的位置:首页 > 其它

POJ 3087 Shuffle'm Up

2015-08-14 19:36 489 查看
Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips,
S1 and S2, each stack containing
C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from
S1
with a chip from S2 as shown below for
C = 5:



The single resultant stack, S12, contains 2 *
C chips. The bottommost chip of S12 is the bottommost chip from
S2. On top of that chip, is the bottommost chip from
S1
. The interleaving process continues taking the 2nd chip from the bottom of
S2 and placing that on S12, followed by the 2nd chip from the bottom of
S1 and so on until the topmost chip from S1 is placed on top of
S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost
C chips from S12 to form a new
S1 and the topmost C chips from
S12 to form a new S2. The shuffle operation may then be repeated to form a new
S12.

For this problem, you will write a program to determine if a particular resultant stack
S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤
N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer
C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and
S2). The second line of each dataset specifies the colors of each of the
C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the
C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through
H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 *
C uppercase letters (A through
H
), representing the colors of the desired result of the shuffling of
S1
and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though
N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1
(−1) for the number of shuffle operations.

Sample Input
2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output
1 2
2 -1

Source
Greater New York 2006

/*

计划上归类是搜索,可能是思想使用的搜索吧...然而并不认为是搜索,读懂题之后用STL 0M飘过。题意是给两列字符(其实是扑克洗牌),先拿第二列再拿第一列以此拿取,每次一个字符。问用几步可以获得第三个字符串,(取成一列字符后再从中间分为两组继续拿取)。

*/

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <cmath>
#include <vector>
#include <cstdio>
#include <map>
#include <set>
const int INF = 0x3f3f3f3f;

using namespace std;

int main()
{
int t,n,ant,sum;
string a,b,c,d;
scanf("%d",&t);
for(int i=1;i<=t;i++)
{
scanf("%d",&ant);
map<string,bool>Str;
bool flag = true;
cin>>a;cin>>b;cin>>c;d="";sum=0;
while(1)
{
sum++;
for(int i=0;i<ant;i++)
{
d+=b[i];d+=a[i];
}
if(d == c)
{
flag = false;
break;
}
else if(Str[d]!=NULL && Str[d] == 1)
break;
else
{
Str[d] = 1;
a = d.substr(0,ant);
b = d.substr(ant,ant*2);
d.clear();
}
}
if(flag)
printf("%d -1\n",i);
else
printf("%d %d\n",i,sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: