您的位置:首页 > 其它

Legal or Not HDU杭电3342【拓扑排序】

2015-08-14 18:54 281 查看
Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions,
many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too
many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian
is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.



Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and
y is x's prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.



Output

For each test case, print in one line the judgement of the messy relationship.

If it is legal, output "YES", otherwise "NO".



Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0




Sample Output

YES
NO




/*
//不能用并查集 ,更不能路径压缩, 并查集是无向边 
#include<stdio.h>
int n;
int per[110];
void init()
{
	for(int i=0;i<n;++i)
	{
		per[i]=i;
	}
}
int find(int x)
{
	if(x==per[x]) return x;
	return per[x]=find(per[x]);
}
bool join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		per[fy]=fx;
		return 0;
	}
	return 1;
}
int main()
{
	int m;
	int a,b;
	while(~scanf("%d%d",&n,&m),n+m)
	{
		init();
		int flag=0;
		while(m--)
		{
			scanf("%d%d",&a,&b);
			if(join(a,b))
			{
				flag=1;
			}
		}
		if(flag)printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}
*/

#include<stdio.h>
#include<string.h>
#define N 110
int indegree
;
bool map

;
int n;
int i,j;
bool topsort()
{
	for(i=1;i<=n;++i)//找n个数 
	{
		int temp=-1;
		for(j=0;j<n;++j)
		{
			if(indegree[j]==0)
			{
				temp=j;
				break;
			}
		}
		if(temp==-1) return 0;
		indegree[temp]=-1;
		for(j=0;j<n;++j)
		{
			if(map[temp][j])
			{
				indegree[j]--;
			}
		}
	}
	return 1;
}
int main()
{
	int m;
	int a,b;
	while(~scanf("%d%d",&n,&m),n+m)
	{
		memset(indegree,0,sizeof(indegree));
		memset(map,0,sizeof(map));
		while(m--)
		{
			scanf("%d%d",&a,&b);
			if(!map[a][b])
			{
				map[a][b]=1;
				indegree[b]++;
			}
		}
		if(topsort()) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: