您的位置:首页 > 其它

Nim HDU2975

2015-08-14 16:03 375 查看
Nim

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1, k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

11110111101

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3

7 11 13

2

1000000000 1000000000

0

Sample Output

3

0

题意: 两个人, 每次选其中一堆,可以拿一个或多个石子。要使得下一状态为失败的状态,也就是说拿走石头后,剩下的各堆石子异或的结果为0。问有多少种拿法。

思路:简单的nim应用。 对每一个数进行操作, 剩下的其他数据异或运算,得到的结果如果小于当前这个数据,可作为一种取法。

a,b,c 三堆石子。 c-a^b=d。 (c-d)^a^b=0。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cmath>
using namespace std;
int nim[1005];
int main()
{
int n, i, ans, res, j;
while(scanf("%d", &n)==1 && n)
{
res = 0;
ans = 0;
for(i = 0; i < n; i++)
{
scanf("%d", &nim[i]);
ans ^= nim[i];
}
if(ans == 0)
{
cout << ans << endl;
continue;
}
for(i = 0; i < n; i++)
{
ans = 0;
for(j = 0; j < n; j++)
{
if(j != i)
ans ^= nim[j];
}
if(nim[i] >= ans)
res++;
}
cout << res << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: