您的位置:首页 > 其它

hdu 5384 Danganronpa (ac自动机)

2015-08-14 13:50 435 查看


Danganronpa

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 360 Accepted Submission(s): 198



Problem Description

Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series' name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are n verbal
evidences, and Stilwell has m "bullets".
Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings Ai,
and bullets are some strings Bj.
The damage to verbal evidence Ai from
the bullet Bj is f(Ai,Bj).

f(A,B)=∑i=1|A|−|B|+1[ A[i...i+|B|−1]=B ]
In other words, f(A,B) is
equal to the times that string B appears
as a substring in string A.

For example: f(ababa,ab)=2, f(ccccc,cc)=4

Stilwell wants to calculate the total damage of each verbal evidence Ai after
shooting all m bullets Bj,
in other words is ∑mj=1f(Ai,Bj).

Input

The first line of the input contains a single number T,
the number of test cases.

For each test case, the first line contains two integers n, m.

Next n lines,
each line contains a string Ai,
describing a verbal evidence.

Next m lines,
each line contains a string Bj,
describing a bullet.

T≤10

For each test case, n,m≤105, 1≤|Ai|,|Bj|≤104, ∑|Ai|≤105, ∑|Bj|≤105

For all test case, ∑|Ai|≤6∗105, ∑|Bj|≤6∗105, Ai and Bj consist
of only lowercase English letters

Output

For each test case, output n lines,
each line contains a integer describing the total damage of Ai from
all m bullets, ∑mj=1f(Ai,Bj).

Sample Input

1
5 6
orz
sto
kirigiri
danganronpa
ooooo
o
kyouko
dangan
ronpa
ooooo
ooooo


Sample Output

1
1
0
3
7


Source

2015 Multi-University Training Contest 8

多校8 1005,裸ac自动机

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;
const int N = 500005;
int que
;
char str
;
string A
;
struct acm {
int cnt;
int next
[26], sum
, fail
;
void clear() {
for (int i = 1; i <= cnt; ++i) {
sum[i] = fail[i] = 0;
for (int j = 0; j < 26; ++j)
next[i][j] = 0;
}
cnt = 1;
for (int i = 0; i < 26; ++i)
next[0][i] = 1;
}
void insert(char str[]) {
int now = 1;
int len = strlen(str);
for (int i = 0; i < len; ++i) {
if (!next[now][str[i] - 'a'])
next[now][str[i] - 'a'] = ++cnt;
now = next[now][str[i] - 'a'];
}
++sum[now];
}
void buildFail() {
int head = 0, tail = 1;
que[0] = 1;
fail[1] = 0;
while (head != tail) {
int now = que[head];
head++;
for (int i = 0; i < 26; ++i) {
int ch = next[now][i];
if (!ch)
continue;
int tmp = fail[now];
while (!next[tmp][i])
tmp = fail[tmp];
fail[ch] = next[tmp][i];
que[tail++] = ch;
}
}
}
void gao(int n) {
for (int l = 0; l < n; ++l) {
int ans = 0, now = 1, len = A[l].length();
for (int i = 0; i < len; ++i) {
while (!next[now][A[l][i] - 'a'])
now = fail[now];
now = next[now][A[l][i] - 'a'];
for (int j = now; j; j = fail[j]) {
ans += sum[j];
}
}
cout << ans << endl;
}
}
void debug() {
for (int i = 0; i <= cnt; ++i) {
printf("id=%3d,fail=%3d,sum=%3d,ch=[\n", i, fail[i], sum[i]);
for (int j = 0; j < 26; ++j)
printf("%2c", j + 'a');
puts("");
for (int j = 0; j < 26; j++)
printf("%2d", next[i][j]);
puts("");
printf("]\n");
}
}
} acm;
int main() {
int T;
ios::sync_with_stdio(false);
cin >> T;
while (T--) {
int n, m;
cin >> n >> m;
for (int i = 0; i < n; ++i)
cin >> A[i];

acm.clear();
for (int i = 0; i < m; ++i) {
cin >> str;
acm.insert(str);
}
acm.buildFail();
//acm.debug();

acm.gao(n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: