您的位置:首页 > 其它

poj 3070 Fibonacci(简单矩阵连乘)

2015-08-14 12:25 435 查看
题目:http://poj.org/problem?id=3070

Fibonacci

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10994Accepted: 7823
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1

Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:



题意如上,没有什么陷阱,简单的矩阵连乘取模。

#include <iostream>
#include <cstdio>
using namespace std;
const int mod=1e4;
struct matrie{
    int m[2][2];
};
matrie A={
    1,1,
    1,0
};
matrie I={
    1,0,
    0,1
};
matrie multi(matrie a,matrie b){
    matrie c;
    for(int i=0;i<2;i++){
        for(int j=0;j<2;j++){
            c.m[i][j]=0;
            for(int k=0;k<2;k++){
                c.m[i][j]+=(a.m[i][k]*b.m[k][j])%mod;
            }
            c.m[i][j]%=mod;
        }
    }
    return c;
}
matrie power(int n){
    matrie ans=I,tmp=A;
    while(n){
         if(n&1)ans=multi(ans,tmp);
         tmp=multi(tmp,tmp);
         n>>=1;
    }
    return ans;
}
int main()
{
    int n;
    while(cin>>n&&n!=-1){
        matrie q=power(n);
        printf("%d\n",q.m[1][0]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: