您的位置:首页 > 其它

POJ2342 Anniversary party 树形dp入门题

2015-08-14 11:02 330 查看
题目链接

[align=center]Anniversary party[/align]

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5234 Accepted: 2975
Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V.
E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating)
attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number
in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:

L K

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line

0 0

Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5

Source
Ural State University Internal Contest October'2000 Students
Session

题意:

将举办一个晚会庆祝校庆,邀请员工参加,为了使晚会更加活跃,决定不同时邀请员工和他的直接上司,每个人都有一个活跃值,该怎么邀请才能使得晚会最活跃。

题解:

树形dp
dp[node][1] += dp[i][0]; i是node的下属,1表示上司(node)去,0表示下属(i)不去
dp[node][0] += max(dp[i][1],dp[i][0]);

//bei
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
using namespace std;
const int Maxn = 6009;

int n;
int dp[Maxn][2],father[Maxn];
bool vis[Maxn];

void tree_dp(int node)
{
int i;
vis[node] = 1;
for (i = 1; i <= n; ++i)
{
if (!vis[i] && father[i] == node)
{
tree_dp(i);
dp[node][1] += dp[i][0];
dp[node][0] += max(dp[i][1],dp[i][0]);
}
}
}

int main()
{
int i;
int f,c,root;
while (~scanf("%d",&n))
{
memset(dp,0,sizeof(dp));
memset(father,0,sizeof(father));
memset(vis,0,sizeof(vis));
for (i = 1; i <= n; ++i)
{
scanf("%d",&dp[i][1]);
}
root = 0;
bool beg = 1;
while (~scanf("%d%d",&c,&f)&&(c||f))
{
father[c] = f;
if (root == c || beg)
{
root = f;
}
}
while (father[root])
{
root = father[root];
}
tree_dp(root);
printf("%d\n",max(dp[root][0],dp[root][1]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息