您的位置:首页 > 其它

HDU 3342 -- Legal or Not【裸拓扑排序 &&水题 && 邻接表实现】

2015-08-14 10:36 435 查看

Legal or Not

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5906 Accepted Submission(s): 2734



Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When
someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are
too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian
is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.


Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which
means x is y's master and y is x's prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.


Output
For each test case, print in one line the judgement of the messy relationship.

If it is legal, output "YES", otherwise "NO".


Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0




Sample Output
YES
NO



裸拓扑排序

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define maxn 110
using namespace std;

struct node {
    int u, v, next;
};

node edge[maxn];
int in[maxn];
int head[maxn], cnt;
int n, m;

void init(){
    cnt = 0;
    memset(head, -1, sizeof(head));
    memset(in, 0, sizeof(in));
}

void add(int u, int v){
    edge[cnt] = {u, v, head[u]};
    head[u] = cnt++;
}

void topsort(){
    int ans = 0;
    queue<int>q;
    for(int i = 0; i < n; ++i){
        if(in[i] == 0){
            q.push(i);
            ans++;
        }
    }
    while(!q.empty()){
        int u = q.front();
        q.pop();
        for(int i = head[u]; i != -1; i = edge[i].next){
            int v = edge[i].v;
            in[v]--;
            if(!in[v]){
                q.push(v);
                ans++;
            }
        }
    }
    if(ans == n)
        printf("YES\n");
    else
        printf("NO\n");
}

int main (){
    while(scanf("%d%d", &n, &m), n || m){
        init();
        while(m--){
            int a, b;
            scanf("%d%d", &a, &b);
            add(a, b);
            in[b]++;
        }
        topsort();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: