您的位置:首页 > 其它

poj2406Power Strings

2015-08-13 23:49 281 查看
Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 37771Accepted: 15632
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

直接KMP:

#include<stdio.h>
#include<string.h>
#define max  1000010
char str[max];
int ans=0,len,p[max];
void Getp()
{
	int i=0,j=-1;
	p[i]=j;
	while(i<len)//求next数组<我用p数组> 
	{
		if(j==-1||str[i]==str[j])
		{
			i++,j++;
			p[i]=j;
		}
		else
		j=p[j];
	}
}
int main()
{
	 while(scanf("%s",str)&&str[0]!='.')
	 {
	 	len=strlen(str);
	  	Getp();
	 	      if(len%(len-p[len])==0)
               printf("%d\n",len/(len-p[len]));//求重复的数量 
               else
               printf("1\n");
	 }
	return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: