您的位置:首页 > 其它

coderforce 560 B

2015-08-13 22:24 232 查看


Description

Gerald bought two very rare paintings at the Sotheby's auction and he now wants to hang them on the wall. For that he bought a special board to attach it to the wall and place the paintings on the board. The board has shape of an
a1 × b1 rectangle, the paintings have shape of a
a2 × b2 and
a3 × b3 rectangles.

Since the paintings are painted in the style of abstract art, it does not matter exactly how they will be rotated, but still, one side of both the board, and each of the paintings must be parallel to the floor. The paintings can touch each other and the
edges of the board, but can not overlap or go beyond the edge of the board. Gerald asks whether it is possible to place the paintings on the board, or is the board he bought not large enough?

Input

The first line contains two space-separated numbers a1 and
b1 — the sides of the board. Next two lines contain numbers
a2, b2, a3
and b3 — the sides of the paintings. All numbers
ai, bi in the input are integers and fit into the range from
1 to 1000.

Output

If the paintings can be placed on the wall, print "YES" (without the quotes), and if they cannot, print "NO" (without the quotes).

Sample Input

Input
3 2
1 3
2 1


Output
YES


Input
5 5
3 3
3 3


Output
NO


Input
4 2
2 3
1 2


Output
YES


Sample Output

0
2
3
5


Hint

That's how we can place the pictures in the first test:



And that's how we can do it in the third one.



分情况讨论即可,注意不要遗漏情况

#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
//freopen("in.txt","r",stdin);
int x,y;
while(scanf("%d%d",&x,&y)!=EOF)
{
int a,b,c,d;
scanf("%d%d%d%d",&a,&b,&c,&d);
if((a+c<=x&&b<=y&&d<=y)||(a+c<=y&&b<=x&&d<=x)||(a+d<=x&&b<=y&&c<=y)||(a+d<=y&&b<=x&&c<=x)||(b+c<=x&&a<=y&&d<=y)||(b+c<=y&&a<=x&&d<=x)||(b+d<=x&&a<=y&&c<=y)||(b+d<=y&&a<=x&&c<=x))
printf("YES\n");
else
printf("NO\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: