您的位置:首页 > 其它

poj 2075 Tangled in Cables

2015-08-13 20:23 381 查看

Tangled in Cables

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 19 Accepted Submission(s) : 6
Problem Description
You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought.
Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the
houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.


Input
Only one town will be given in an input.

The first line gives the length of cable on the spool as a real number.

The second line contains the number of houses, N

The next N lines give the name of each house's owner. Each name consists of up to 20 characters {az,AZ,09} and contains no whitespace or punctuation.

Next line: M, number of paths between houses

next M lines in the form

< house name A > < house name B > < distance >

Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.


Output
The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output

Not enough cable

If there is enough cable, then output

Need < X > miles of cable

Print X to the nearest tenth of a mile (0.1).


Sample Input
100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0




Sample Output
Need 10.2 miles of cable
这题是最小树的变形,将各个名字转化为点,最小树求即可!当然还有长度要求!代码:
#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
#define N 1010
char s[10000][30];
double map

,cost
,m,outcome;
int country,road,v
;
void prim()
{
	int i,j,next;
	double mincost;
	memset(v,0,sizeof(v));
	for(i=0;i<country;i++)
	{
	 cost[i]=map[0][i];
   
	 }
	 v[0]=1;
	 for(i=1;i<country;i++)//寻找最短的距离 
	  {
	  	mincost=INF;
	  	for(j=0;j<country;j++)
	  	 {
	  	 	if(!v[j]&&mincost>cost[j])
	  	 	{
	  	 		mincost=cost[j];
	  	 		next=j;
			}
		   }
		   outcome+=mincost;
		   v[next]=1;
		   for(j=0;j<country;j++)//更新路径 
		    {
		    	if(!v[j]&&cost[j]>map[next][j])
		    	{
		    		cost[j]=map[next][j];
				}
			}
	  }
}
int main()
{
	int i,j;
	double l;
	char a[30],b[30];
	while(scanf("%lf",&m)!=EOF)
	{
	scanf("%d",&country);
	for(i=0;i< country;i++)
	 scanf("%s",s[i]);
	 scanf("%d",&road);
	 for(i=0;i<country;i++)
	  {
	  	for(j=0;j<country;j++)
	  	 {
	  	 	if(i==j)
	  	 	map[i][j]=0;
	  	 	else
	  	 	map[i][j]=INF;
		   }
	  }
	 for(i=0;i<road;i++)//字符转化为点 
	  {
	  	scanf("%s%s%lf",a,b,&l);
	  	int k,t;
	  	for(j=0;j<country;j++)
	  	{
	  		if(strcmp(s[j],a)==0)
	  		 k=j; 
		}
		  for(j=0;j<country;j++)
		   {
		   	
		   		if(strcmp(s[j],b)==0)
	  		      t=j;
		   }
		    map[t][k]=map[k][t]=l;
	  }
	  prim();
	  if(outcome<=m)
	  printf("Need %.1f miles of cable\n",outcome);
	  else
	  printf("Not enough cable\n");
	return 0;
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: