您的位置:首页 > 其它

HDU 1325 Is It A Tree?

2015-08-13 19:05 162 查看
[align=left]Problem Description[/align]
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

[align=left]Input[/align]
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist
of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

[align=left]Output[/align]
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

[align=left]Sample Input[/align]

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1


[align=left]Sample Output[/align]

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
题意:给你一些有向的点。推断对于给定的点。能不能形成一棵树一棵树的定义:1、无环2、2个点不能指向1个点3、仅仅有1个根,一棵树思路:题意就是思路了,用并查集来实现
AC代码:[code]#include<stdio.h>
#include<string.h>
#define N 1010
int bian
,point
;	//bian为有向的边,point为点
int flag;
int find(int x)		//并查集的基本操作
{
if(bian[x]==-1)
return x;
return  bian[x]=find(bian[x]);
}
int main()
{
int u,v,i,cnt=1,tot;
memset(bian,-1,sizeof(bian));
memset(point,0,sizeof(point));
flag=0;
while(scanf("%d %d",&u,&v)!=EOF)
{
if(u==-1&&v==-1)break;
point[u]=1;			//标记存在的点
point[v]=1;
if(u+v==0)
{
tot=0;
for(i=1;i<110;i++)
{
if(point[i]&&bian[i]==-1)
{
tot++;
if(tot>1){
flag=1;
break;
}
}
}
if(flag)printf("Case %d is not a tree.\n",cnt++);
else
printf("Case %d is a tree.\n",cnt++);
memset(bian,-1,sizeof(bian));
memset(point,0,sizeof(point));
flag=0;
continue;
}
int a=find(u);		//寻找父节点
int b=find(v);
if(b!=v||a==b)
{
flag=1;
continue;
}
bian[b]=a;
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: