您的位置:首页 > 其它

hdu2120 Ice_cream's world I (并查集查找环的个数)

2015-08-13 18:28 399 查看


Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 887 Accepted Submission(s): 517



Problem Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world.
But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.



Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and
B are distinct). Terminate by end of file.



Output

Output the maximum number of ACMers who will be awarded.

One answer one line.



Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7




Sample Output

3




Author

Wiskey



Source

HDU 2007-10 Programming Contest_WarmUp



Recommend

威士忌 | We have carefully selected several similar problems for you: 2122 2118 2119 2121 2117



Statistic | Submit | Discuss | Note

这道题的意思就是查找一个图里面有几个环。

怪我一切知识都学的太死了。唉,起初竟然没想到。。多希望再来几个这样的题

让我捡漏。。

#include <stdio.h>
int fa[1005];
int find(int x)
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
bool comb(int a,int b)
{
	a=find(a);
	b=find(b);
	if(a==b)//如果根相等就是出现了环
	return true;
	else
	{
		fa[a]=b;
		return false;
	}
}
void init(int n)
{
	for(int i=0;i<n;i++)
	fa[i]=i;
}
int main()
{
	int n,k;
	while(scanf("%d %d",&n,&k)!=EOF)
	{
		init(n);
		int sum=0;
		for(int i=0;i<k;i++)
		{
			int a,b;
			scanf("%d %d",&a,&b);
			if(comb(a,b))
			sum++;
		}
		printf("%d\n",sum);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: