您的位置:首页 > 其它

动态规划——C编辑最短距离

2015-08-13 16:52 375 查看
C - 编辑距离
时间限制: 1000女士 内存限制: 65536KB 64位输入输出格式: %I64d & %I64u
提交 状态

描述

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

Deletion: a letter in x is missing in y at a corresponding position.

Insertion: a letter in y is missing in x at a corresponding position.

Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C
| | |       |   |   | |

A G T * C * T G A C G C


Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C
|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C


and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in yis n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC


Sample Output

4
题目大意: 给出两个字符串X,Y,求出从X——>Y的最小操作次数,只可以删除,添加,修改一个字符。
解题思路:

也是DP中比较经典的问题

d[i][j]表示第一个串到i位置,和第二个串到j位置的最短编辑距离

d[i][j]

如果a[i]==b[j]

d[i][j]=min(d[i-1][j-1],d[i-1][j]+1,d[i][j-1]);

否则d[i][j]=min(d[i-1][j-1]+1,d[i-1][j]+1,d[i][j-1]);

程序代码:


#include <cstdio>
#include <iostream>
using namespace std;
const int M=1100;
char a[M],b[M] ;
int d[M][M];
int main()
{
int n,i,j,l,r;
while( scanf("%d%s",&l,a+1)!=EOF)
{
scanf("%d%s",&r,b+1);
int len=max(l,r);
for(i=0;i<=len;i++)
{
d[i][0]=i;
d[0][i]=i;
}
for(i=1;i<=l;i++)
for(j=1;j<=r;j++)
{
d[i][j]=min(d[i-1][j]+1,d[i][j-1]+1);
if(a[i]==b[j])
d[i][j]=d[i-1][j-1];
else
d[i][j]=min(d[i][j],d[i-1][j-1]+1);
}
printf("%d\n",d[l][r]);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: