您的位置:首页 > 其它

九度oj 1024

2015-08-13 15:29 239 查看
题目描述:
    省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
输入:
    测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M (N, M < =100 );随后的 N 行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
输出:
    对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
样例输入:
3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100

样例输出:
3
?

来源:
2007年浙江大学计算机及软件工程研究生机试真题

#include<iostream>
#include<algorithm>
#include<vector>
#include<string.h>
#include<stdio.h>
using namespace std;
int tree[200];
int findroot(int x)
{
if(tree[x]==-1)
return x;
else
return findroot(tree[x]);
}
struct edge{
int a,b;
int cost;
bool operator<( const edge &a)const
{
return cost<a.cost;
}
}edge[200];
int main()
{
int n,m;
while(cin>>n>>m)
{
if(n==0) break;
for(int i=1;i<=n;i++)
{
cin>>edge[i].a>>edge[i].b>>edge[i].cost;
}
sort(edge+1,edge+1+n);
memset(tree,-1,sizeof(tree));
int ans=0;
for(int i=1;i<=n;i++)
{
int a=findroot(edge[i].a);
int b=findroot(edge[i].b);
if(a!=b)
{
tree[a]=b;
ans+=edge[i].cost;
}
}
int cnt=0,i;
for( i=1;i<=m;i++)
{
if(tree[i]==-1)
{
cnt++;
}
}
if(cnt>1){
cout<<"?"<<endl;
continue;
}
else
{
cout<<ans<<endl;}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: