您的位置:首页 > 其它

PAT 1029. Median (25)

2015-08-13 15:19 465 查看


1029. Median (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median
of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed
that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.
Sample Input
4 11 12 13 14
5 9 10 15 16 17

Sample Output
13


有点惊讶于这道题竟然值25分。其实只要把输入全都放在一个vector里面,sort以后输出中间数就好了。。。。

代码如下:

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
int N;
vector<long int> lists;
int main(void)
{
scanf("%d",&N);
for(int i = 0; i < N; i++){
long int tmp;
scanf("%ld",&tmp);
lists.push_back(tmp);
}
scanf("%d",&N);
for(int i = 0; i < N; i++){
long int tmp;
scanf("%ld",&tmp);
lists.push_back(tmp);
}
sort(lists.begin(),lists.end());
int pos = (lists.size()+1)/2 -1;
printf("%ld\n",lists[pos]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: