您的位置:首页 > 其它

POJ---1159-Palindrome(01DP)

2015-08-13 14:49 387 查看
E - Palindrome
Time Limit:3000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd


Sample Output

2


#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <algorithm>
using namespace std;
char s1[5001],s2[5001],s;
int dp[2][5001];
int main()
{
int n,i,j;
while(cin>>n)
{
memset(dp,0,sizeof(dp));
for(i=1,j=n; i<=n; i++,j--)
{
cin>>s;
//scanf("%c",&s);
s1[i]=s2[j]=s;
}
int maxl=0,a,b;
for(i=1; i<=n; i++)
for(j=1; j<=n; j++)
{
a=i%2,b=(i-1)%2;
if(s1[i]==s2[j])
dp[a][j]=dp[b][j-1]+1;
else
dp[a][j]=max(dp[b][j],dp[a][j-1]);
if(maxl<dp[a][j])
maxl=dp[a][j];
}
cout<<n-maxl<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: