您的位置:首页 > 其它

PAT 1028. List Sorting (25)

2015-08-13 14:48 411 查看


1028. List Sorting (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record
of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records
must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90


这道题主要就是要对结构体进行排序。然而最后一个点我始终运行超时,在网上找了别人的代码对比后,觉得自己的代码应该没什么问题呀。

结果最后发现把cin,cout换成了scanf,printf就顺利过了最后一个case。。。天真的我以为只要算法时间复杂度对了就不会超时的来着。。。没想到败给了cin。。

这里放个人家的代码:

#include<iostream>
#include<algorithm>
#include<vector>
#include<string.h>

typedef struct Student
{
int id;
char name[20];
int g;
}Student;

int C;
bool cmp(Student a, Student b)
{
if(C == 1)
return a.id < b.id;
else if(C == 2)
{
if( strcmp(a.name, b.name) == 0 )
return a.id < b.id;
else return strcmp(a.name, b.name)<0;
}
else if(C == 3)
{
if(a.g == b.g)
return a.id < b.id;
else return a.g < b.g;
}
}
int main()
{
int N;
while( scanf("%d%d", &N, &C) != EOF )
{
std::vector<Student> stuVec(N);
for(int i = 0; i < N; ++i)
scanf("%d%s%d", &stuVec[i].id, stuVec[i].name, &stuVec[i].g);
//sort
std::sort(stuVec.begin(), stuVec.end(), cmp);
for(int i = 0; i < N; ++i)
printf("%06d %s %d\n", stuVec[i].id, stuVec[i].name, stuVec[i].g);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: