您的位置:首页 > 其它

POJ2752 Seek the Name, Seek the Fame

2015-08-12 18:55 441 查看
Seek the Name, Seek the Fame

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 14203Accepted: 7077
Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative
little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa

Sample Output
2 4 9 18
1 2 3 4 5


题意:找一个字符串中所有前缀和后缀相同的子串

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>

using namespace std;

char s[1000009];
int nt[1000009];
int len;

void getnext()
{
    int k=-1,j=0;
    nt[0]=-1;

    while(j<len)
    {
        if(k<0 || s[j]==s[k])
        {
            j++;
            k++;
            nt[j]=k;
        }
        else
            k=nt[k];
    }
}

int ans[400009];

int main()
{
    while(~scanf("%s",s))
    {
        len=strlen(s);
        getnext();

        for(int i=0;i<=len;i++)
            cout<<nt[i]<<" ";
            cout<<endl;

        int cnt=0;
        ans[0]=len;
        for(int i=nt[len];i>0;i=nt[i])//next数组的性质。
            ans[++cnt]=i;

        for(int i=cnt;i>0;i--)
            cout<<ans[i]<<" ";
        cout<<ans[0]<<endl;

    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: