您的位置:首页 > 其它

Ice_cream’s world III

2015-08-12 18:43 387 查看

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1212    Accepted Submission(s): 401


[align=left]Problem Description[/align]
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every
city to the capital. The project’s cost should be as less as better.
 

[align=left]Input[/align]
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

[align=left]Output[/align]
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

[align=left]Sample Input[/align]

2 1
0 1 10

4 0

 

[align=left]Sample Output[/align]

10

impossible  
#include<stdio.h>
#include<string.h>
#include<math.h>
#define mx 0x3f3f3f
int n,m;
int g[1100][1100];
void prim()
{
int i,j,k,v,min,sum=0;
int dis[1100],vis[1100];
memset(vis,0,sizeof(vis));
for(i=0;i<n;i++)
{
dis[i]=g[0][i];
}
dis[0]=0;
vis[0]=1;
for(v=1;v<n;v++)
{
min=mx;
k=0;
for(i=1;i<n;i++)
{
if(!vis[i]&&dis[i]<min)
{
min=dis[i];
k=i;
}
}
vis[k]=1;
if(min==mx)
{
printf("impossible\n");
return ;
}
sum+=min;
for(i=0;i<n;i++)
{
if(!vis[i]&&dis[i]>g[k][i])
dis[i]=g[k][i];
}
}
printf("%d\n",sum);
}
int main(){
int i,j,l,x,y;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(x=0;x<n;x++)//初始化g,不然会错
{
for(y=0;y<n;y++)
{
if(x==y)
g[x][y]=0;
else
g[x][y]=mx;
}
}
while(m--)
{
scanf("%d%d%d",&i,&j,&l);
if(g[i][j]>l)
g[i][j]=g[j][i]=l;
}
prim();
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: