您的位置:首页 > 其它

BestCoder Round #50 (div.2)-----C The mook jong

2015-08-12 17:22 495 查看


The mook jong

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/65536 K (Java/Others)

Problem Description



ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in
a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).

Input

There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)

Output

Print the ways in a single line for each case.

Sample Input

1
2
3
4
5
6


Sample Output

1
2
3
5
8
12


分析:找规律题,推导公式。最后得到的公式是ans[i]=ans[i-3]+1+ans[i-1]。

CODE:

#include <iostream>
using namespace std;

int main()
{
int n;
long long ans[66]={0,1,2,3};
for(int i=4;i<66;i++){
ans[i]=ans[i-3]+1+ans[i-1];
}
while(cin>>n){
cout<<ans
<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: