您的位置:首页 > 其它

HDU 1358 Period

2015-08-12 16:57 351 查看
Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the
largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) � the size of the string S. The second line contains the string S. The input file ends with a line,
having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0


Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4


////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

分析:

KMP变形,找到最短的匹配子串。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char B[1000005];
int nxt[1000005];
int m,cas;
void makenext()
{
int l,r;
l=-1;r=0;nxt[0]=-1;
while(r<=m){
if(l==-1||B[l]==B[r]){
nxt[++r]=++l;
}else{
l=nxt[l];
}
}
}

int main()
{
//  freopen("in.txt","r",stdin);
cas=1;
while(~scanf("%d",&m)&&m){
scanf("%s",B);
makenext();
printf("Test case #%d\n",cas++);
for(int i=2;i<=m;++i){
if(nxt[i]&&i%(i-nxt[i])==0){
printf("%d %d\n",i,i/(i-nxt[i]));
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: