您的位置:首页 > 理论基础 > 数据结构算法

数据结构上机测试2-1:单链表操作A

2015-08-12 15:29 411 查看

数据结构上机测试2-1:单链表操作A

题目描述

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。

输入

第一行输入数据个数n;

第二行依次输入n个整数;

第三行输入欲删除数据m。

输出

第一行输出原始单链表的长度;

第二行依次输出原始单链表的数据;

第三行输出完成删除后的单链表长度;

第四行依次输出完成删除后的单链表数据。

示例输入

10
56 25 12 33 66 54 7 12 33 12
12


示例输出

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33


#include<bits/stdc++.h>
using namespace std;
struct  node
{
    int data;
    struct node *next;
}*p,*q,*head,*tail;
void display(struct node *head);
int main()
{
    int i,n,m;
    cin>>n;
    head=new node;
    head->next=NULL;
    tail=head;
    for(i=0; i<n; i++)
    {
        p=new node;
        cin>>p->data;
        p->next=tail->next;
        tail->next=p;
        tail=p;
    }
    cin>>m;
    cout<<n<<endl;
    display(head);
    p=head->next;
    q=head;
    while(p)
    {
        if(p->data==m)
        {
            q->next=p->next;
            free(p);
            p->next=q;
            n--;
        }
        q=p;
        p=p->next;
    }
    cout<<n<<endl;
    display(head);
}
void display(struct node *head)
{
p=head->next;
    while(p)
    {
        if(p->next)
        {
            cout<<p->data<<" ";
        }
        else
            cout<<p->data<<endl;
        p=p->next;
    }
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: