您的位置:首页 > 编程语言 > C语言/C++

Asteroids

2015-08-12 14:47 686 查看
G - Asteroids
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2


Sample Output

2


Hint

INPUT DETAILS: 

The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 

.X. 

.X.

OUTPUT DETAILS: 

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
#define MAX 550
int n;//x,y的顶点数
int g[MAX][MAX],cx[MAX],cy[MAX],mk[MAX];
//矩阵数组,顶点x数组,顶点y数组,标记y数组是否出现过。
int path(int u)//从x找y的匹配边
{
for(int i=1;i<=n;++i)//从第一个点找到最后一个点
{
if(g[u][i]&&!mk[i])//如果没有与y连接的边,且边要未用过
{
mk[i]=1;
if(cy[i]==-1||path(cy[i]))
//第一次用Yi顶点,或用了Yi顶点但是可以从x中找到另一条边与他匹配
{
cx[u]=i;
cy[i]=u;
return 1;
}
}
}
return 0;
}
int main()
{
/*freopen("input.txt","r",stdin);*/
int i,m,k,t;
while(~scanf("%d%d",&n,&m))
{
memset(g,0,sizeof(g));
while(m--)
{
scanf("%d%d",&k,&t);
g[k][t] = 1;
}
memset(cx,0xff,sizeof(cx));memset(cy,0xff,sizeof(cy));
int res=0;
for(i=1;i<=n;++i)
{
if(cx[i]==-1)//未使用过的x点去找与y的连接边
{
memset(mk,0,sizeof(mk));
res+=path(i);
}
}
printf("%d\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c++ 二分图