您的位置:首页 > 其它

HDU 3371 Connect the Cities (克鲁斯卡尔)

2015-08-12 12:41 369 查看
Problem Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t
want to take too much money.

Input

The first line contains the number of test cases.

Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected
cities.

To make it easy, the cities are signed from 1 to n.

Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.

Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6


Sample Output

1


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
int s,e,m;
}s[25111];
int fa[555];
int find_Set(int x)
{
int r=x;
while(fa[r]!=r) r=fa[r];
int i=x,j;
while(i!=r) {
j=fa[i];
fa[i]=r;
i=j;
}
return r;
}
int cmp(node u,node v)
{
return u.m<v.m;
}
int main()
{
int T,n,m,k,i,j,fx,fy,x,y,t,sum,temp;
scanf("%d",&T);
while(T--)
{
sum=0;
scanf("%d%d%d",&n,&m,&k);
temp=n-1;
for(i=1;i<=n;++i)
fa[i]=i;
for(i=1;i<=m;++i)
scanf("%d%d%d",&s[i].s,&s[i].e,&s[i].m);
for(i=1;i<=k;++i)
{
scanf("%d",&t);
scanf("%d",&x);
for(j=2;j<=t;j++)
{
scanf("%d",&y);
fx=find_Set(x);
fy=find_Set(y);
if(fx!=fy) {
fa[fx]=fy;
temp--;
}
}
}

sort(s+1,s+1+m,cmp);
for(i=1;i<=m;++i)
{
fx=find_Set(s[i].s);
fy=find_Set(s[i].e);
if(fx!=fy)
{//printf("fx=%d %d\n",fx,fy);
fa[fx]=fy;
sum+=s[i].m;
temp--;
}
}
//for(i=1;i<=n;i++)
//printf("%d ",find_Set(i));
//printf("\n");

if(temp!=0) printf("-1\n");
else printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: