您的位置:首页 > 其它

POJ 2418 Hardwood Species (字典树||MAP)

2015-08-12 11:32 387 查看
Hardwood Species

Time Limit: 10000MSMemory Limit: 65536K
Total Submissions: 20684Accepted: 8108
Description
Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.

America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the
hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber
such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.
Input
Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.
Output
Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.
Sample Input
Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output
Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483

题目大意:就是查看所有的树种在在全部树中所占的比例。
思路:裸的字典树或這MAP,看完题目后,1)如何建树有些茫然,因为之前建的树都是全为大写或小写字母,这个是什么都有。。
2)如何按照字典序输出,且不重复。

Trie:

#include<iostream>
#include<cstring>//用模板加string
#include<cstdio>
#include<queue>
#include<algorithm>
#define SUM 250001
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;
int s;
struct node
{
    int vis;
    node *next[301];
};
struct no
{
    char s[32];
    int r;
}w[10010];
char now[32];
int sum=0,cnt=0;
node *init()
{
    node *p;
    p=new node ;
    memset(p->next,NULL,sizeof(p->next));//因为不知道每个字符的范围,所以干脆全部都治空
    p->vis=0;//用于记录当前单词出现的次数
    return p;
}
int op(no a,no b)
{
    return strcmp(a.s,b.s)<0;
}
void bu(node *root,char *now)
{
    char *c=now;//<span id="transmark"></span>将当前的单词,赋值给C,便于将此单词保存在w[].s中
    while(*now!='\0')
    {
        int i=*now;//直接将此单词的ASCII作为下标进行建树
        if(root->next[i]==NULL)
        {
            root->next[i]=init();
        }
        root=root->next[i];
        now++;//移动下一个字节
    }
    if(root->vis==0)
    {
        strcpy(w[sum++].s,c);//注意 赋值的时候不能将now赋值,因为此时的now已经是单词的结尾,
    }
    root->vis++;
}
void look(node *root,char *per)
{
    char *c=per;
    int i,j,k;
    while(*per!='\0')
    {
        i=*per;
        if(!root->next[i])
            return ;
        root=root->next[i];
        per++;
    }
    printf("%s %.4f\n",c,(float)(root->vis*100)/cnt);//如果没有在执行到当前语句返回,证明则树中有此单词
}
int main()
{
    int i,j,k;
    node *root;
    root=new node ;
    root=init();//初始化
    while(gets(now)!=NULL)
    {
        if(!strcmp(now,""))
            break;
        cnt++;//记录总共的树的数量
        bu(root,now);//建树
    }
    sort(w,w+sum,op);//进行W内的字符串排序
    for(i=0;i<sum;i++)
    {
        look(root,w[i].s);
    }
    return 0;
}
[code]
map:

#include <iostream>
#include <cstdio>
#include <cstring>
#include<string>
#include <map>
#include<algorithm>
#include<stdlib.h>
#include<ctype.h>
#include<queue>
#include<math.h>
char s[40];
using namespace std;
int main()
{
    int n,m,i;
    double x;
    map<string,int>mp;
    map<string,int>::iterator cnt;
    n=0;
    while(gets(s)!=NULL)
    {
        if(!strcmp(s,""))//有无此句都对只不过在Linux下不能直接出结果,若无需要CTRL+D
            break;
        n++;
        mp[s]++;
    }
    for(cnt=mp.begin(); cnt!=mp.end(); cnt++)
    {
        x=(cnt->second*100.0)/n;
        printf("%s %.4lf\n",cnt->first.c_str(),x);
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: