您的位置:首页 > 其它

zoj2100 Seeding

2015-08-12 11:08 302 查看
Seeding

Time Limit: 2 Seconds
Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.
Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it
into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?

Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.

Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.

Sample Input

4 4

.S..

.S..

....

....

4 4

....

...S

....

...S

0 0



Sample Output


YES

NO

题目主要看能否走完所有地块,搜索即可

代码:

#include<stdio.h>
#include<string.h>
#define max 10
int n,m,sum=0,flag=0;
char map[max][max];
int dx[4]={1,0,0,-1};//四个方向 
int dy[4]={0,1,-1,0};
void Getmap()
{
	int i,j;
	for(i=1;i<=n;i++)//取图 
 {
 	 getchar();
	 for(j=1;j<=m;j++)
	   {
	   	scanf("%c",&map[i][j]);
	   	if(map[i][j]=='S')
	   	sum++;
	   }
 }
}
int  judge(int x,int y) //判断是否出界或是走过 
{
	if(x<1||x>n||y<1||y>m)
	return 0;
	if(map[x][y]=='S')
	return 0;
	return 1;
}
void dfs(int x,int y)
{
	int i;
	++sum;
	map[x][y]='S';
	if(sum==n*m)//是否遍历全部地块 
	{
	flag=1;
	return ;
    }
	for(i=0;i<4;i++)//搜索 
	{
		int nx=x+dx[i];
		int ny=y+dy[i];
		if(judge(nx,ny))
		{
			dfs(nx,ny);
		}
	}   sum--;
	    map[x][y]='.';
}
int main()
{
	while(scanf("%d%d",&n,&m),n||m)
	{
		sum=0;
		Getmap();
		flag=0;
		dfs(1,1);
		if(flag==0)
		printf("NO\n");
		else
		printf("YES\n");
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: