您的位置:首页 > 其它

poj3258 二分最小值最大化

2015-08-12 11:07 344 查看
如题:http://poj.org/problem?id=3258



River Hopscotch

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 9150Accepted: 3951
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end,
L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks,
N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance
Di from the start (0 <
Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to
M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of
M rocks.

Input
Line 1: Three space-separated integers: L,
N, and M

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing
M rocks
Sample Input
25 5 2
2
14
11
21
17

Sample Output
4

Hint
Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
Source
USACO 2006 December Silver






思路:二分距离,对于每个距离d判断当前的N个石头能否删除小于M个小于距离d的石头,如果能,代表距离还要增大,否则,距离减小。



#include<iostream>

#include<cstring>

#include<cstdio>

#include<algorithm>

using namespace std;

#define MAXN 50005

int a[MAXN];

int C(int d,int N,int M) //N个石头是否能删除掉小于M个<d距离的石头

{

int i;

int del=0;

int sum=0;

for(i=1;i<N;i++)

{

if((sum+=a[i]-a[i-1])<d)

del++;

else

sum=0;

}

if(del<=M)

return 1;

return 0;

}

int main()

{

// freopen("C:\\1.txt","r",stdin);

int L,N,M;

int i;

cin>>L>>N>>M;

for(i=1;i<=N;i++)

cin>>a[i];

a[N+1]=L;

sort(a,a+N+2);

int l=0,r=L+1;

while(r-l>1)

{

int mid=(l+r)/2;

if(C(mid,N+2,M))

l=mid;

else

r=mid;

}

printf("%d\n",l);

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: