您的位置:首页 > 其它

hdu 1028 对某个数n的m划分数

2015-08-12 10:34 375 查看

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15687 Accepted Submission(s): 11063



[align=left]Problem Description[/align]
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:

N=a[1]+a[2]+a[3]+...+a[m];

a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

4 = 4;

4 = 3 + 1;

4 = 2 + 2;

4 = 2 + 1 + 1;

4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

[align=left]Input[/align]
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

[align=left]Output[/align]
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

[align=left]Sample Input[/align]

4
10
20


[align=left]Sample Output[/align]

5
42
627


[align=left]Author[/align]
Ignatius.L

[align=left]Recommend[/align]
We have carefully selected several similar problems for you: 1171 1398 2152 1709 1059

//hdu 1028
//dp[i][j]代表j的小于i划分的总数,则dp[i][j]=dp[i-1][j]+dp[i][j-i];
//dp[i-1][j]肯定是前面划分的数的总和,dp[i][j-i]则是从第i-1个划分到第i个划分的增量;
//如果这i个划分全部大于0,他们的和肯定是j,对于每个数,把它减去1,奇迹的得到了j-i的i划分;
//因为他们有i个,每个都减去1,自然总共减去了i,减去后发现是j-i的i划分,所以增量就是这个。
#include<bitset>
#include<map>
#include<vector>
#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<stack>
#include<queue>
#include<set>
#define inf 0x3f3f3f3f
#define mem(a,x) memset(a,x,sizeof(a))

using namespace std;

typedef long long ll;
typedef pair<int,int> pii;

inline int in()
{
int res=0;
char c;
while((c=getchar())<'0' || c>'9');
while(c>='0' && c<='9')res=res*10+c-'0',c=getchar();
return res;
}
ll dp[122][122];
int main()
{
dp[0][0]=1;
for(int i=1;i<=120;i++) //外层循环是划分个数
{
for(int j=0;j<=120;j++) //内层循环是对于数j的划分
{
if(j-i>=0)
{
dp[i][j]=dp[i-1][j]+dp[i][j-i];
}
else dp[i][j]=dp[i-1][j];
}
}
//for(int i=2;i<=20;i++)cout<<dp[i][i]<<" ";
int n;
while(~scanf("%d",&n))
{
printf("%I64d\n",dp

);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: