您的位置:首页 > 其它

POJ 2349 Arctic Network(最小生成树--prime)

2015-08-12 10:08 393 查看
Arctic Network

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13163 Accepted: 4272
Description
The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver
and some outposts will in addition have a satellite channel.

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers.
Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y)
coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750

Sample Output
212.13

ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 10010
#define INF 0xfffffff
using namespace std;
double pri[MAXN][MAXN];
int v[MAXN];
double dis[MAXN];
double b[MAXN];
int n,c;
double sum;
struct s
{
int x;
int y;
}a[MAXN];
bool cmp(double a,double b)
{
return a>b;
}
void prime()
{
int i,j,k;
double min;
memset(v,0,sizeof(v));
memset(b,0,sizeof(b));
for(i=1;i<=n;i++)
dis[i]=pri[1][i];
v[1]=1;
sum=0;
c=1;
for(i=0;i<n;i++)
{
min=INF;
for(j=1;j<=n;j++)
{
if(v[j]==0&&dis[j]<min)
{
min=dis[j];
k=j;
}
}
if(min==INF)
break;
v[k]=1;
b[c++]=min;//记录所选边的权值
sum+=min;
for(j=1;j<=n;j++)
{
if(v[j]==0&&dis[j]>pri[k][j])
dis[j]=pri[k][j];
}
}
}
int main()
{
int t,i,j,m;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&m,&n);
for(i=1;i<=n;i++)
{
scanf("%d%d",&a[i].x,&a[i].y);
}
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
double k;
k=sqrt(1.0*((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y)));
pri[i][j]=pri[j][i]=k;
}
}
prime();
sort(b+1,b+n,cmp);//对边进行排序,取第m条边
printf("%.2lf\n",b[m]);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: