您的位置:首页 > 其它

hdu 3665 Seaside(最短路)

2015-08-12 08:54 495 查看
Seaside

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1253 Accepted Submission(s): 915

点击打开链接

[align=left]Problem Description[/align]

XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed
that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.

Input

There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then
Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi
and LMi, which means that the distance between the i-th town and the SMi town is LMi.

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.

Sample Input
5

1 0

1 1

2 0

2 3

3 1

1 1

4 100

0 1

0 1

Sample Output

2

题目大意就是求得从起点开始到达海岸边最短的路,这里到达岸边的方案不止一种,要找出最短的。

单源最短路,很裸的Dijkstra

AC代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<set>
#include<map>
#define INF 0x3f3f3f3f
using namespace std;
struct Node
{
int id;
int flag;
}node[15];
int d[15],v[15],w[15][15];
int main()
{
int N;
int n;
int p,dis;
while(scanf("%d",&N)!=EOF)
{
for(int i=0;i<N;i++)
for(int j=0;j<N;j++)
w[i][j]=INF;
for(int i=0;i<N;i++)
node[i].id=i;
for(int i=0;i<N;i++)
{
scanf("%d%d",&n,&node[i].flag);
for(int j=0;j<n;j++)
{
scanf("%d%d",&p,&dis);
w[i][p]=dis;
}
}
memset(v,0,sizeof(v));
for(int i=0;i<N;i++)
d[i]=(i==0 ? 0 : INF);
for(int i=0;i<N;i++)
{
int x,m=INF;
for(int y=0;y<N;y++)
if(!v[y] && d[y]<m){m=d[x=y];}
v[x]=1;
for(int y=0;y<N;y++)
if(!v[y] && w[x][y]!=INF)
d[y]=min(d[y],d[x]+w[x][y]);
}
int ans=INF;
for(int i=0;i<N;i++)
if(node[i].flag)
ans=min(ans,d[i]);
printf("%d\n",ans);
}
return 0;
}


[align=center][/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: