您的位置:首页 > 其它

hdu 2199 Can you solve this equation?

2015-08-11 23:06 411 查看

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13292 Accepted Submission(s): 5937



[align=left]Problem Description[/align]
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

[align=left]Output[/align]
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and
100.

[align=left]Sample Input[/align]

2
100
-4


[align=left]Sample Output[/align]

1.6152
No solution!

源代码(二分查找)

//1000
#include<stdio.h>
#include<math.h>

double f(double x)
{
return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}

int main()
{
int t;
double x1,x2,x3,y,y1,y2,y3;
scanf("%d",&t);
while(t--)
{
x1=0;
x2=100;
scanf("%lf",&y);
y1=f(x1)-y;
y2=f(x2)-y;
if(y1>0||y2<0)
printf("No solution!\n");
else
{
while(fabs(f(x1)-f(x2))>=0.00001)
{
x3=(x1+x2)/2;
y3=f(x3)-y;
if(y3>0)
x2=x3;
else
x1=x3;
y1=f(x1)-y;
y2=f(x2)-y;
}
printf("%.4lf\n",x3);
}

}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: