您的位置:首页 > 编程语言 > C语言/C++

团体队列

2015-08-11 20:36 513 查看
F - 团体队列
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld
& %llu
Submit Status

Description





Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life.
At lunch time the queue in front of the Mensa is a team queue, for example.

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right
behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

Input 

The input file will contain one or more test cases. Each test case begins with the number of teams t ( 

).
Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.
Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output 

For each test case, first print a line saying `` Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test
case, even after the last one.

Sample Input 

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0


Sample Output 

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001


    与AC代码相差不多,就是多了个标记数组,为什么就会运行错误了。这题看起来复杂,其实做起来也挺复杂。相当于·要模拟一个大队列,大队列又有多个小队列。
AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<queue>
#include<map>
using namespace std;
#define T 1010
int main()
{
/*freopen("input.txt","r",stdin);*/
int n,m,i,j,k,cnt=0;
while(~scanf("%d",&n)&&n)
{
printf("Scenario #%d\n",++cnt);
queue<int> st,a[T];
map<int,int> s;
for(i=0;i<n;++i)
{
scanf("%d",&m);
while(m--)
{
scanf("%d",&k);
s[k] = i;
}
}
char str[10];
while(scanf("%s",&str)&&str[0]!='S')
{
if(str[0]=='E')
{
scanf("%d",&k);
if(a[s[k]].empty())st.push(s[k]);
a[s[k]].push(k);
}
else
{
k = st.front();
printf("%d\n",a[k].front());a[k].pop();
if(a[k].empty())st.pop();
}
}
printf("\n");
}
return 0;
}

运行错误代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<queue>
#include<map>
using namespace std;
#define T 1010
bool bo[T];
int main()
{
//freopen("input.txt","r",stdin);
int n,m,i,j,k,cnt=0;
while(~scanf("%d",&n)&&n)
{
memset(bo,false,sizeof(bo));
queue<int> st,a[T];
map<int,int> s;
for(i=0;i<n;++i)
{
scanf("%d",&m);
while(m--)
{
scanf("%d",&k);
s[k] = i;
}
}
char str[10];
printf("Scenario #%d\n",++cnt);
while(scanf("%s",&str)&&str[0]!='S')
{
if(str[0]=='E')
{
scanf("%d",&k);
if(!bo[s[k]]){
st.push(s[k]),bo[s[k]]=true;
}a[s[k]].push(k);
}
else
{
k = st.front();
printf("%d\n",a[k].front());
a[k].pop(); if(a[k].empty())st.pop();
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c++