您的位置:首页 > 其它

HDU 5372 Segment Game 树状数组

2015-08-11 20:33 288 查看
链接


Segment Game

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 273 Accepted Submission(s): 48



Problem Description

Lillian is a clever girl so that she has lots of fans and often receives gifts from her fans.

One day Lillian gets some segments from her fans Lawson with lengths of 1,2,3... and she intends to display them by adding them to a number line.At the i-th add operation,she will put the segment with length of i on the number line.Every time she put the segment
on the line,she will count how many entire segments on that segment.During the operation ,she may delete some segments on the line.(Segments are mutually independent)



Input

There are multiple test cases.

The first line of each case contains a integer n — the number of operations(1<=n<=2∗105,∑n<=7∗105)

Next n lines contain the descriptions of the operatons,one operation per line.Each operation contains two integers a , b.

if a is 0,it means add operation that Lilian put a segment on the position b(|b|<109)
of the line.

(For the i-th add operation,she will put the segment on [b,b+i] of the line, with length of i.)

if a is 1,it means delete operation that Lilian will delete the segment which was added at the b-th add operation.



Output

For i-th case,the first line output the test case number.

Then for each add operation,ouput how many entire segments on the segment which Lillian newly adds.



Sample Input

3
0 0
0 3
0 1
5
0 1
0 0
1 1
0 1
0 0




Sample Output

Case #1:
0
0
0
Case #2:
0
1
0
2
Hint
For the second case in the sample:

At the first add operation,Lillian adds a segment [1,2] on the line.

At the second add operation,Lillian adds a segment [0,2] on the line.

At the delete operation,Lillian deletes a segment which added at the first add operation.

At the third add operation,Lillian adds a segment [1,4] on the line.

At the fourth add operation,Lillian adds a segment [0,4] on the line




Source

2015 Multi-University Training Contest 7
题意:

每次插入一个线段,或删除一个已存在的线段,每次插入后输出当前插入的线段能完整覆盖存在的几条线段。

题解:对于新插入的线段,查询有多少个线段左端点大于等于该线段的左端点。 再查询有多少个线段的右端点大于该线段右端点, 两者之差就是答案。用两个树状数组搞定。时间复杂度nlogn

一共就4种情况,画画图应该能发现。。

#pragma comment(linker, "/STACK:102400000,102400000")
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstring>
#include <queue>
#include <set>
#include <map>
#include <vector>
using namespace std;
template <class T>
inline bool rd(T &ret) {
	char c; int sgn;
	if (c = getchar(), c == EOF) return 0;
	while (c != '-' && (c<'0' || c>'9')) c = getchar();
	sgn = (c == '-') ? -1 : 1;
	ret = (c == '-') ? 0 : (c - '0');
	while (c = getchar(), c >= '0'&&c <= '9') ret = ret * 10 + (c - '0');
	ret *= sgn;
	return 1;
}
template <class T>
inline void pt(T x) {
	if (x < 0) {
		putchar('-');
		x = -x;
	}
	if (x > 9) pt(x / 10);
	putchar(x % 10 + '0');
}
typedef pair<int, int> pii;
typedef long long ll;
const int N = 450007;
struct Tree {
	int c
, maxn;
	void init(int n) { maxn = n; for (int i = 0; i <= n; i++)c[i] = 0; }
	int lowbit(int x) { return x&-x; }
	int sum(int x) {
		int ans = 0;
		while (x)ans += c[x], x -= lowbit(x);
		return ans;
	}
	void update(int pos, int val) {
		while (pos <= maxn)c[pos] += val, pos += lowbit(pos);
	}
}A, B;
int n;
set<pii> s;
int op
, l
, r
;
pii a
;
vector<int>G;
int main() {
	int cas = 0;
	while (cin>>n) {
		G.clear();
		int top = 0;
		for (int i = 1; i <= n; i++) {
			rd(op[i]), rd(l[i]);
			if (op[i] == 0)
			{
				G.push_back(l[i]);
				r[i] = l[i] + (++top);
				G.push_back(r[i]);
			}
		}
		printf("Case #%d:\n", ++cas);
		sort(G.begin(), G.end()); G.erase(unique(G.begin(), G.end()), G.end());
		top = 0;
		for (int i = 1; i <= n; i++)
			if (op[i] == 0) {
				l[i] = lower_bound(G.begin(), G.end(), l[i]) - G.begin() + 1;
				r[i] = lower_bound(G.begin(), G.end(), r[i]) - G.begin() + 1;
				a[++top] = { l[i], r[i] };
			}
		A.init(G.size()); B.init(G.size());
		int all = 0;
		for (int i = 1; i <= n; i++)
		{
			if (op[i] == 0)
			{
				int ans = B.sum(r[i]);
				ans -= A.sum(l[i]-1);
				pt(ans); putchar('\n');
				A.update(l[i], 1);
				B.update(r[i], 1);
				all++;
			}
			else {
				A.update(a[l[i]].first, -1);
				B.update(a[l[i]].second, -1);
				all--;
			}
		}
	}
	return 0;
}
/*
99
7
1 2 2 1 3 !1 2
/*
1
????0
1 8 3 7 2
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: