您的位置:首页 > 其它

1048. Find Coins (25)

2015-08-11 20:00 302 查看

1048. Find Coins (25)

时间限制50 ms 内存限制65536 kB 代码长度限制16000 B 判题程序Standard作者CHEN, Yue Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.Input Specification:Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.Output Specification:For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.Sample Input 1:8 15 1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

有N个钱币,要付账15,

在N个钱币里面看看有没有两个正好和为15的。如果有多个,那么找V1比较小的那个,要自己先排个序。

(PS:一开始理解错了以为在原来的队伍里面找相邻的)

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月11日 19:48答案正确251048C++ (g++ 4.7.2)29760datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确130812/12
1答案正确13082/2
2答案正确13843/3
3答案正确295602/2
4答案正确247603/3
5答案正确13081/1
6答案正确13082/2

#include<iostream>  
#include<algorithm>
using namespace std; 
bool coinsCmp(const int &A, const int &B){ return A < B; }
int main()
{
  int N, M,V11,V22,temp;
  bool find;
  int *coins;
  cin >> N >> M;
  V22 = N; 
  coins = new int
;  
  while (V22--)cin >> coins[V22];
  find =  false; 
  sort(coins, coins + N, coinsCmp);
  V11 = 0; 
  V22 = N - 1;
  while (!find&&V11 < V22)
  {
    temp = coins[V22] + coins[V11];
    if (temp == M) 
      find = true;  
    else if (temp>M)V22--;
    else V11++;
  }
  if (find)cout << coins[V11 ]<< " " <<coins[ V22 ]<< endl;
  else cout << "No Solution" << endl; 
  delete[]coins;
  system("pause");
  return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: