您的位置:首页 > 其它

poj-3253-sdutoj-2127-哈夫曼树-优先队列

2015-08-11 18:39 267 查看
Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needsN (1 ≤
N ≤ 20,000) planks of wood, each having some integer lengthLi (1 ≤
Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into theN planks (i.e., whose length is the sum of the lengths
Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of theN-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create theN planks. FJ knows that he can cut the board in various different orders which will
result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer N, the number of planks

Lines 2..N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to makeN-1 cuts
Sample Input
3
8
5
8

Sample Output
34


第一道优先队列,记录一下啊

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

int main()
{
    priority_queue<int,vector<int>,greater<int> > que;
    int n;
    long long sum = 0;
    while(~scanf("%d",&n))
    {
        sum = 0;
        int x;
        while(n--)
        {
          scanf("%d",&x);
          que.push(x);
        }
        while(que.size()>1)
        {
            int x = que.top();
            que.pop();
            int y = que.top();
            que.pop();
            sum= sum+x+y;
            que.push(x+y);
        }
        if(sum==0)
        {
            printf("%d\n",x);
        }
        else
        printf("%lld\n",sum);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: