您的位置:首页 > 其它

POJ2236

2015-08-11 18:34 423 查看
A. Wireless Network

Discription

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

1. “O p” (1 <= p <= N), which means repairing computer p.

2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1

0 1

0 2

0 3

0 4

O 1

O 2

O 4

S 1 4

O 3

S 1 4

Sample Output

FAIL

SUCCESS

第一行给出电脑数N和D,两台电脑间最大的、可以直接通讯的距离。接下来N行是这N台电脑的坐标。

再往下是两种操作:

1. “O p” (1 <= p <= N), which means repairing computer p.

2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

1.O p 修电脑p

2.S p q 测试pq之间是否可以通信

还是个并查集的问题,把距离小于最大通讯距离的同时已经修好的电脑按顺序加入即可

#include "iostream"
#include "cstdio"
#include "cstring"
#include "string.h"

using namespace std;

struct node
{
int pre;
int x,y;
};
int N,D;
node d[1005];

int find(int x)
{
return x == d[x].pre ? x : find(d[x].pre);
}

void join(const node p1, const node p2)
{
int root1, root2;
root1 = find(p1.pre);
root2 = find(p2.pre);
if(root1 != root2)
if((p1.x - p2.x) * (p1.x - p2.x) + (p1.y - p2.y) * (p1.y - p2.y) <= D* D)
d[root2].pre = root1;
}

int main()
{

scanf("%d%d",&N,&D);
bool use[1005];

memset(use,false,sizeof(use));
for(int i = 1; i <= N; ++i)
d[i].pre = i;
for(int i=1;i<=N;i++)
{
scanf("%d%d",&d[i].x,&d[i].y);
}
char op;
while(scanf("%c",&op)!=EOF)
{
if(op=='O')
{
int p;
scanf("%d",&p);
use[p]=true;
for(int i=1;i<=N;i++)
{
if(use[i]==true&&i!=p)
join(d[i],d[p]);
}
}
if(op=='S')
{
int p,q;
scanf("%d%d",&p,&q);
if(find(p)==find(q))
{
printf("SUCCESS\n");
}
else
printf("FAIL\n");
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 2236 acm 并查集