您的位置:首页 > 其它

hdoj-1130-How Many Trees?【卡特兰数】

2015-08-11 18:02 393 查看

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3224 Accepted Submission(s): 1870



[align=left]Problem Description[/align]
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node
with label x in O(n log n) average time, where n is the size of the tree (number of vertices).

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree?

[align=left]Input[/align]
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.

[align=left]Output[/align]
You have to print a line in the output for each entry with the answer to the previous question.

[align=left]Sample Input[/align]

1
2
3


[align=left]Sample Output[/align]

1
2
5


[align=left]Source[/align]
UVA

[align=left]Recommend[/align]
Eddy | We have carefully selected several similar problems for you:

1133
2067
1267
1100
1124

#include<stdio.h>
#include<string.h>
const int maxn=500;
int catalan[101][maxn];
void make(){
catalan[1][0]=1;
int i,j,t,res;
int temp[maxn];
memset(temp,0,sizeof(temp));
for(i=2;i<=100;++i){
t=4*i-2;
for(j=0;j<maxn;++j){
catalan[i][j]+=catalan[i-1][j]*t;

}
for(j=0;j<maxn;++j){
if(catalan[i][j]>=10){
catalan[i][j+1]+=catalan[i][j]/10;
catalan[i][j]%=10;
}
}
t=i+1;res=0;
for(j=maxn-1;j>=0;--j){
res=res*10+catalan[i][j];
temp[j]=res/t;
res%=t;
}
for(j=maxn-1;j>=0;--j){
catalan[i][j]=temp[j];
}
}

}
int main(){
make();
int n;
while(~scanf("%d",&n)){
int i=maxn-1;
while(catalan
[i]==0) --i;
for(;i>=0;--i){
printf("%d",catalan
[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: