您的位置:首页 > 其它

克鲁斯卡尔(Kruskal)算法 Agri-Net

2015-08-11 16:37 337 查看
 
克鲁斯卡尔(Kruskal)算法:先将权值从小到大排序,再用并查集思想
 
 
Agri-Net

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45184 Accepted: 18553
Description
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

Input
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another.
Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this
problem.
Output
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output
28

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct note{
int q,z,cost;
}s[10100];
int per[110];
int sum,n,k;
bool cmp(note a1,note a2)
{
return a1.cost<a2.cost;
}
void init()
{
for(int i=1;i<=n;i++)
per[i]=i;
}
int fun(int x)
{
int r=x;
while(per[r]!=r)
r=per[r];
per[x]=r;
return r;
}
int join(int x,int y)
{
int fx=fun(x);
int fy=fun(y);
if(fx!=fy)
{
per[fx]=fy;
return 1;
}
return 0;
}
int kru()
{
int j=0,i;
init();
sort(s,s+k,cmp);
sum=0;
for(i=0;i<k;i++)
{
if(join(s[i].q,s[i].z))
{
j++;
sum+=s[i].cost;
}
if(j==n-1)
return sum;
}
return j;
}
int main()
{
int cost1,i,j;
while(scanf("%d",&n)!=EOF)
{
k=0;
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
scanf("%d",&cost1);
if(i!=j){

s[k].q=i;
s[k].z=j;
s[k++].cost=cost1;
}
}
}
printf("%d\n",kru());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: