您的位置:首页 > 其它

UVa 3266 Tian Ji -- The Horse Racing

2015-08-11 16:16 441 查看
Description



Here is a famous story in Chinese history.

That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.
Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver
dollars from the loser.
Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian.
Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.
It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And
how do you think of Tian Ji, the high ranked official in China?



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses -- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a
too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integern (
n

1000) on the first line, which is the number of horses on each side. The next
n integers on the second line are the speeds of Tian's horses. Then the nextn integers on the third line are the speeds of the king's horses. The input ends with a line that has a single
`0' after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0


Sample Output
200
0
0


#include <stdio.h>
#include <algorithm>
using namespace std;
int ji[1010], king[1010];

int main() {
int n;
while (scanf("%d", &n) == 1 && n) {
for (int i = 0; i < n; i++) scanf("%d", &ji[i]);
for (int i = 0; i < n; i++) scanf("%d", &king[i]);
sort(ji, ji + n);
sort(king, king + n);

int sum = 0;
int min_ji = 0, min_king = 0;
int max_ji = n - 1, max_king = n - 1;

while (min_ji <= max_ji) {
if (ji[min_ji] > king[min_king]) {
min_ji++;
min_king++;
sum += 200;
}
else if (ji[min_ji] < king[min_king]) {
min_ji++;
max_king--;
sum -= 200;
}
else if (ji[max_ji] <= king[max_king]) {
if (ji[min_ji] < king[max_king])
sum -= 200;
min_ji++;
max_king--;
}
else {
max_ji--;
max_king--;
sum += 200;
}
}
printf("%d\n", sum);
}
return 0;
}


#include <stdio.h>
#include <algorithm>
using namespace std;
int ji[1010], king[1010];

int main() {
int n;
while (scanf("%d", &n) == 1 && n) {
for (int i = 0; i < n; i++) scanf("%d", &ji[i]);
for (int i = 0; i < n; i++) scanf("%d", &king[i]);
sort(ji, ji + n);
sort(king, king + n);

int sum = 0;
int a1 = 0, a2 = n - 1;
int b1 = 0, b2 = n - 1;

while (n--) {
if (ji[a1] > king[b1]) { a1++; b1++; sum++; }
else if (ji[a2] > king[b2]) { a2--; b2; sum--; }
else if (ji[a1] < king[b2]) { a1++; b2--; sum--;}
else { a1++; b2--; }
}
printf("%d\n", sum * 200);
}
return 0;
}


1.田忌最慢的马 > 齐王最慢的马 将田忌最慢的马 与 齐王最慢的马比 +200

2.田忌最慢的马 < 齐王最慢的马 将田忌最慢的马 与 齐王最快的马比 -200

3.田忌最慢的马 = 齐王最慢的马

a.田忌最快的马 > 齐王最快的马 将田忌最快的马 与 齐王最快的马比 +200

b.田忌最快的马 <= 齐王最快的马 将田忌最慢的马 与 齐王最快的马比 -200

若 齐王最快的马 = 田忌最慢的马

例:

2

1 1

1 1

这时不交换。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: