您的位置:首页 > 其它

Prime Ring Problem

2015-08-11 15:26 357 查看
[align=left]Problem Description[/align]
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



 

[align=left]Input[/align]
n (0 < n < 20).

 

[align=left]Output[/align]
The output format is shown as sample below. Each row r
4000
epresents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

[align=left]Sample Input[/align]

6
8

 

[align=left]Sample Output[/align]

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题解:数据量小,深搜。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

bool visited[50];
bool prim[100];
int pre[100];

void prime()
{
memset(prim,true,sizeof(prim));
prim[2] = false;
for(int i = 2;i <= 99;i++)
{
for(int j = 2 * i;j < 100;j += i)
{
prim[j] = false;
}
}
}

void print(int x)
{
if(pre[x] == x)
{
printf("1");
return;
}
print(pre[x]);
printf(" %d",x);
}

void dfs(int x,int t,int n)
{
if(t == n - 1) //找到最后一个需要判断前驱和还有和1的和是不是素数
{
if(prim[x + pre[x]] && prim[x + 1])
{
print(x);
printf("\n");
}
return;
}
visited[x] = true; //表示该数目前可行
for(int i = 2;i <= n;i++)
{
if(!visited[i] && prim[i + x]) //前面没有出现过并且可行
{
pre[i] = x;
dfs(i,t + 1,n);
}
}
visited[x] = false; //该数字遍历完了,标记为没访问过
}

int main()
{
int n;
prime();
int t = 1;
memset(visited,false,sizeof(visited));
while(scanf("%d",&n) != EOF)
{
printf("Case %d:\n",t++);
for(int i = 1;i <= 60;i++)
{
pre[i] = i;
}
dfs(1,0,n);
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: