您的位置:首页 > 其它

Message Flood

2015-08-11 14:41 405 查看


Message Flood




Time Limit: 1500ms Memory limit: 65536K 有疑问?点这里^_^


题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer
"What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse,
Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he
needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed
to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic
strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

输出

For each case, print one integer in one line which indicates the number of left friends he must send.

示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0


示例输出

3


来源

第9届中山大学程序设计竞赛预选赛

view plaincopyprint如果您复制代码时出现行号,请点击左边的“view
plain”后再复制

#include<stdio.h>

#include<string.h>

#include<algorithm>

#include<iostream>

#include<stdlib.h>

#include<math.h>

#include<ctype.h>

#include<queue>

#include<map>///map的头文件

#include<set>

using namespace std;

int main()

{

int n, m, len;

char s[30];

set<string>map;

while(~scanf("%d", &n) && n)

{

scanf("%d", &m);

getchar();

map.clear();///清空map

for(int i=0;i<n;i++)

{

gets(s);

len=strlen(s);

for(int j=0;j<len;j++)

s[j]=tolower(s[j]);

map.insert(s);

}

for(int i=0;i<m;i++)

{

gets(s);

len=strlen(s);

for(int j=0;j<len;j++)

{

s[j]=tolower(s[j]);

}

map.erase(s);///表示从map中删除s元素

}

printf("%d\n", map.size());

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: