您的位置:首页 > 其它

1083. List Grades (25)

2015-08-11 14:17 267 查看
题目如下:

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:
N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name
 ID
 grade

grade1 grade2


where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is
no student's grade in that interval, output "NONE" instead.
Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:
NONE


简单的排序题,将输入的数据按照成绩降序排序,然后过滤着输出,没有输出输出NONE。

#include <iostream>
#include <vector>
#include <algorithm>
#include <stdio.h>

using namespace std;

struct Person{

    string name,id;
    int grade;

    bool operator < (const Person& p) const{
        return grade > p.grade;
    }

    Person(string _n, string _id, int _g){
        name = _n;
        id = _id;
        grade = _g;
    }

};

int main()
{
    int N;
    string name,id;
    int grade;
    vector<Person> persons;
    cin >> N;
    for(int i = 0; i < N; i++){
        cin >> name >> id >> grade;
        persons.push_back(Person(name,id,grade));
    }
    int grade1,grade2;
    cin >> grade1 >> grade2;
    sort(persons.begin(),persons.end());
    bool hasData = false;
    for(int i = 0; i < N; i++){
        if(persons[i].grade < grade1 || persons[i].grade > grade2) continue;
        printf("%s %s\n",persons[i].name.c_str(),persons[i].id.c_str());
        hasData = true;
    }
    if(!hasData){
        cout << "NONE" << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: