您的位置:首页 > 其它

PAT 1036. Boys vs Girls (25)

2015-08-11 13:49 459 查看

1036. Boys vs Girls (25)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:
Mary EE990830
Joe Math990112
6

Sample Input 2:
1
Jean M AA980920 60

Sample Output 2:
Absent
Jean AA980920
NA

将男女分别分开,然后再用sort即可以得到结果


#include <iostream>
#include <vector>
#include <string>
#include <algorithm>

using namespace std;

struct Student
{
string name;
string id;
int score;
};

bool cmp(Student s1, Student s2)
{
return s1.score < s2.score;
}

int main()
{
int stuNum;
cin >> stuNum;
vector<Student> male, female;
for (int i = 0; i < stuNum; i++)
{
Student stu;
char gender;
cin >> stu.name >> gender >> stu.id >> stu.score;
if (gender == 'M')
male.push_back(stu);
else
female.push_back(stu);
}
sort(male.begin(), male.end(), cmp);
sort(female.begin(), female.end(), cmp);
if (female.empty())
cout << "Absent" << endl;
else
cout << female.back().name << " " << female.back().id << endl;
if (male.empty())
cout << "Absent" << endl;
else
cout << male.front().name << " " << male.front().id << endl;
if (female.empty() || male.empty())
cout << "NA";
else
cout << female.back().score - male.front().score;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: