您的位置:首页 > 其它

HDOJ2222Keywords Search【AC自动机模板题】

2015-08-11 11:35 435 查看

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 44074    Accepted Submission(s): 13848


[align=left]Problem Description[/align]
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.

Wiskey also wants to bring this feature to his image retrieval system.

Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

 

[align=left]Input[/align]
First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.

 

[align=left]Output[/align]
Print how many keywords are contained in the description.
 

[align=left]Sample Input[/align]

1
5
she
he
say
shr
her
yasherhs

 

[align=left]Sample Output[/align]

3

 

[align=left]Author[/align]
Wiskey
 

AC-自动机模板题暨我的第一道AC-自动机题

AC自动机参考资料:AC自动机讲解 邝斌博客 :邝斌博客

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
using namespace std;
struct Node{
int next[500010][26],fail[500010],end[500010];
int L,root;
int newNode(){
for(int i=0;i<26;++i){
next[L][i]=-1;
}
end[L++]=0;
return L-1;
}
void init(){
L=0;
root=newNode();
}
void insert(char *s){
int i,len=strlen(s);
int now=root;
for(i=0;i<len;++i){
if(next[now][s[i]-'a']==-1){
next[now][s[i]-'a']=newNode();
}
now=next[now][s[i]-'a'];
}
end[now]++;
}
void build(){
fail[root]=root;
queue<int>Q;
for(int i=0;i<26;++i){
if(next[root][i]==-1){
next[root][i]=root;
}
else{
fail[next[root][i]]=root;
Q.push(next[root][i]);
}
}
while(!Q.empty()){
int now=Q.front();Q.pop();
for(int i=0;i<26;++i){
if(next[now][i]==-1){
next[now][i]=next[fail[now]][i];
}
else{
fail[next[now][i]]=next[fail[now]][i];
Q.push(next[now][i]);
}
}
}
}
int query(char *s){
int ans=0;
int now=root;
int len=strlen(s);
for(int i=0;i<len;++i){
now=next[now][s[i]-'a'];
int temp=now;
while(temp!=root){
ans+=end[temp];
end[temp]=0;
temp=fail[temp];
}
}
return ans;
}
};
char str[1000010];
Node ac;
int main()
{
int i,j,t,n;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
ac.init();
while(n--){
scanf("%s",str);
ac.insert(str);
}
ac.build();
scanf("%s",str);
printf("%d\n",ac.query(str));
}
return 0;
}


 

 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDOJ2222Keywords Sea